搜索
您的当前位置:首页正文

[C/C++]1008 Elevator (20 分)

来源:欧得旅游网

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

电梯从0层开始,上一层用6s,下一层用4s,到达停5s,最后不需要返回0层

经测试,没有next==now的情况

#include<stdio.h>

int main()
{
	int n;
	scanf("%d",&n);
	int now = 0, next, time = 0;
	for(int i=0; i<n; i++){
		scanf("%d",&next);
		next>now ? time += (next-now)*6 : time += (now-next)*4;
		now = next; 
	}
	time += n*5;
	printf("%d",time);
	
	return 0;
 } 

因篇幅问题不能全部显示,请点此查看更多更全内容

Top